Announcement

Collapse
No announcement yet.

Mercedes-Benz w204 US to EU

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Mercedes-Benz w204 US to EU

    Hi everyone,

    I got 2009 C-class w204 with US Comand NTG4 nav system.
    The problem is that it won't accept Europe v6.0 map (A204 827 47 59).

    I read about changing region code from US to ECE, but I didn't try that.

    Does the region code unlocks this, or there is some other method for doing that ?


    Thanks a lot in advance


    ::cheers::
    + 250 posts @ oldGPSU

  • #2
    Re: Mercedes-Benz w204 US to EU

    I need that info too

    Comment


    • #3
      Re: Mercedes-Benz w204 US to EU

      I did that, changed to ECE region CODE2, now I got EU system. But i need update for software to make EU maps working.

      EU system works, it have 100.1 radio stations and stuff like TA.

      Here is details:

      I think the 2008 needs a COMAND update before the newest NAV update.. but here's the method for 2009+ W204:

      Enter engineering menu, and go to Software Parameters
      Change the Region to ECE (2)
      Turn the car off for 5 minutes.
      Turn the car on, and scan the radio dial, the US setting will only scan odd decimals (i.e. 100.1), EU setting will scan all decimals (i.e. 100.0). If you radio is scanning all decimals, the update has taken effect, if not turn the car off and continue to wait for the settings to finish applying.
      Insert European Navigation DVD, and follow the on-screen instructions.
      You will need to leave the car idling for about an hour and a half, and there's a disc change after about an hour and 15 mintues.

      Comment


      • #4
        Re: Mercedes-Benz w204 US to EU

        Hey tolt,

        As far as I been told, you have to update comand to at least 01/2010 Telematics SW version.
        For an update, you need to take your car to the MB service and update it there.

        After that try this method that you posted above.

        I'm not able to try this yet, but I will in a few days.

        If you succeed, please let us know!

        ::cheers::
        + 250 posts @ oldGPSU

        Comment


        • #5
          Re: Mercedes-Benz w204 US to EU

          I tried that method and that works, I changed to EU mode and works.

          Only need A204 870 75 96 code DVD that works on UMI, 2010 maps. You have that maybe?

          Comment


          • #6
            Re: Mercedes-Benz w204 US to EU

            Wait, wait, wait . . .

            You said "A204 870 75 96" ?
            That DVD map is for Mercedes UMI (Universal Media Interface) navigation system.

            Do you have UMI (Universal Media Interface) or Comand APS NTG4 navigation in your MB ???

            ================================================== ======
            NTG4 unit:


            UMI unit:

            ================================================== ======

            Enter engineering menu, and go to Software Parameters
            Change the Region to ECE (2)
            Turn the car off for 5 minutes.
            Turn the car on, and scan the radio dial, the US setting will only scan odd decimals (i.e. 100.1), EU setting will scan all decimals (i.e. 100.0). If you radio is scanning all decimals, the update has taken effect, if not turn the car off and continue to wait for the settings to finish applying.
            Insert European Navigation DVD, and follow the on-screen instructions.
            You will need to leave the car idling for about an hour and a half, and there's a disc change after about an hour and 15 mintues.
            This method you wrote is posted on the MBWorld forums and it refers to Comand NTG4 navigation unit.
            NTG4 isn't using "A204 870 75 96" map, but this one: "A204 827 47 59" v6.0 2009/2010 map...

            ???

            ::cheers::
            Last edited by NavCore; 2nd June 2010, 20:26.
            + 250 posts @ oldGPSU

            Comment


            • #7
              Re: Mercedes-Benz w204 US to EU

              I have DVD that open and goes out, it's first picture UMI (Universal Media Interface) so I need that DVD.

              It's same thing, i changed options and works in EU Mode.

              Need only this A204 870 75 96 DVD 2010 maps

              Comment


              • #8
                Re: Mercedes-Benz w204 US to EU

                Sorry man, I named those pictures wrongly.

                Check again, first one that opens and goes out is Comand APS NTG4 and it needs "A204 827 47 59" v6.0 2009/2010 map...

                :: cheers ::
                + 250 posts @ oldGPSU

                Comment


                • #9
                  Re: Mercedes-Benz w204 US to EU

                  I have this one!!

                  Code:
                  http://www.youtube.com/watch?v=SiNEPKtS4U0&feature=related
                  One that comes out screen .. which one is it?!?!

                  Comment


                  • #10
                    Re: Mercedes-Benz w204 US to EU

                    Originally posted by tolt View Post
                    I have this one!!

                    Code:
                    http://www.youtube.com/watch?v=SiNEPKtS4U0&feature=related
                    One that comes out screen .. which one is it?!?!

                    Comand APS NTG4
                    + 250 posts @ oldGPSU

                    Comment


                    • #11
                      Re: Mercedes-Benz w204 US to EU

                      How!?

                      It's not posible. in product list it says UMI unit?!

                      Code:
                      http://www.emercedesbenz.com/Images/Jan07/18_Its_Official_2008_Mercedes_Benz_C_Class/111642906c3952_019.jpg
                      I have this one

                      Comment


                      • #12
                        Re: Mercedes-Benz w204 US to EU

                        Originally posted by tolt View Post
                        How!?

                        It's not posible. in product list it says UMI unit?!

                        Code:
                        http://www.emercedesbenz.com/Images/Jan07/18_Its_Official_2008_Mercedes_Benz_C_Class/111642906c3952_019.jpg
                        I have this one
                        # UMI - Universal Multimedia Interface (see pictures at the bottom):
                        Code:
                        http://www.autospectator.com/cars/mercedes-benz/0028802-new-universal-media-interface-mercedes-benz-accessories-gmbh
                        # NTG4:
                        Code:
                        http://www.navi-nec.de/shop/product_info.php?language=en&info=p34_Mercedes-Comand-C-Class-W204-Changer.html&XTCsid=hvwpfqohkvk
                        # Search here for COMAND-APS (NTG4):
                        Code:
                        http://www.mercupgrades.com/COMAND+++All+about+the+different+Mercedes+COMAND+systems-article-54.html

                        You need more proofs ?
                        + 250 posts @ oldGPSU

                        Comment


                        • #13
                          Re: Mercedes-Benz w204 US to EU

                          No hehe, you rock

                          So what navigation I need then?

                          I tried this one but doesnt work :/ Is that one correct?

                          Comment


                          • #14
                            Re: Mercedes-Benz w204 US to EU

                            Yes, it is --> Comand APS NTG4 Europe v6.0 2009/2010 map (two DVD's).

                            Did you tried to load this map after you changed region to ECE via engeneering menu ?

                            Many users confirmed that this works ?!!

                            :: cheers ::
                            + 250 posts @ oldGPSU

                            Comment


                            • #15
                              Re: Mercedes-Benz w204 US to EU

                              Yep, I changed to ECE, and region code 2, EU options available now but DVD doesnt work.

                              I burned with IMGBurn, Nero and Alcohol and none of them works. Dont know why. maybe need update of navi?


                              Here says C Klase > 03/07 ... that is from 03/07 or to .. 03/07 ?

                              Comment

                              Working...
                              X