Results 1 to 1 of 1

Thread: no Sound for speed cam +TMC +can't save new speed cam.

  1. #1
    u1988 is offline Sergeant
    Join Date
    Aug 2012
    Thanked 7 Times in 4 Posts

    Question no Sound for speed cam +TMC +can't save new speed cam.

    I have Novogo Z905 and iGO Primo v9.2.4.271232 - GoldMaster & iGO Primo v9.6.13.267029 - November 2012 (orginal igo More/amigo + TMC)

    and I have a few problems:

    1.There is no sound for any speed cams (only a few that came with the new maps the rest no sound hebrew or english)

    2.Can't save new speed cams or other warnings (speed/red light...) after turning the device on it's won't show (save)
    only on the old igo amigo it won't delete after rest the device
    I most add that I use the files: SpeedcamUpdates.spud + speedcam.spdb + speedcam.txt
    from 2 websites that giving for free new update speed cams (but only one of them woring I think speedcam.txt)

    3. I can't turn on the TMC on Novogo Z905 ?
    but noting working only the old igo amigo that came with the device...(old maps can't update)

    4.there is a new versions for IGO?
    iGO All Programs (Android - iOS - WinCE - Windows Mobile) + World Maps

    5.Is it posible to conncet WIFI head unit to this GPS and add TMC by 3G?

    anyone can help me?
    thank you!
    Last edited by u1988; 4th April 2013 at 20:59.

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts