GPSUNDERGROUND FORUM IS ON SALE
Page 1 of 4 123 ... LastLast
Results 1 to 10 of 31
Like Tree1Likes

Thread: Converting Sony NV-U93TW to IGO - advice please

  1. #1
    22merlin is offline Lance Corporal
    Join Date
    Aug 2010
    Posts
    14
    Thanks
    0
    Thanked 3 Times in 2 Posts

    Converting Sony NV-U93TW to IGO - advice please

    I have had a good look through the forums and have a reasonable grasp of how to proceed - so thank you to everyone so far.
    However, I am a cautious soul and given that there is a possibility that I may not get the GPS to work [based on some of the other posts] I want to fully back up the original.
    I know that I can rename and effectively keep the original folders and files - but not sure about the map, a 1.8GB map of Europe.
    As far as I understand it - the flash drive [Mounted volume] is 2GB - so I can't add IGO supported maps as I will run out of room and I've not been able to move the Sony map either in W7 or XP.
    The Sony accepts Memory Stick Duo [does anyone know to what capacity ?] so could I run IGO from the memory card and leave the original Sony software intact on the flash drive ?
    Sorry to ask so many questions in one go - but it would be great to hear from anyone who has done this already.
    Kind regards.

  2. The Following 2 Users Say Thank You to 22merlin For This Useful Post:


  3. #2
    22merlin is offline Lance Corporal
    Join Date
    Aug 2010
    Posts
    14
    Thanks
    0
    Thanked 3 Times in 2 Posts

    Re: Converting Sony NV-U93TW to IGO - advice please

    OK - so I took the plunge and as I feared when using the new software the GPS receiver is not found.
    I have tried to install Primo, IGO8 and Amigo. All install OK - but none of them identify the GPS receiver - and both IGO8 and Amigo say that the GPS receiver is switched off [Primo just continually looks for it].
    I have used sys.txt / not used sys.txt; have tried various port & Baud combinations; have edited the mscr file / not edited the file - and I am at a loss as to what to do now.
    Could there be something in the set up that either doesn't switch on or switches off the GPS receiver ?
    In the original Sony set up there is a file called spgps.ini file that is not included in the new settings - should I incorporate any / all of this ? put the text in sys.txt ? Anyone got any ideas ?
    This is the text from the original Sony sys.ini file....

    [PosSys]
    Sensor1=Default Sensor Gps
    Positioner=Default Positioner
    MapMatcher=Default MapMatcher
    Simulation=Default Simulation

    [Default Positioner]
    SmoothTime=7

    [Default Sensor Gps]
    DataType=GPS
    Connection=Default Sensor Gps Serial
    Parser=Default Sensor Gps Parser

    [Default Sensor Gps Serial]
    ConnectionType=1
    Port=3
    BaudRate=38400
    TimeOut=5

    [Default MapMatcher]
    IgnoreOneWay=0
    GPSMode=4

    [Default Sensor Gps Parser]
    AutoDetectEnabled=1
    AutoReconnectTimeout=4000
    AutoDetectTimeout=-1
    ParserFormat1=GGA_VTG
    ParserFormat2=GGA_RMC

    [GGA_VTG]
    Type=NMEA
    Name=GPS with GGA and VTG messages
    Input1=GPGGA,utctime,latitude,ns,longitude,ew,qual ity,satellites,hdop,altitude,,,,,
    Input2=GPVTG,course,,,,,,speed,

    [GGA_RMC]
    Type=NMEA
    Name=GPS with GGA and RMC messages
    Input1=GPGGA,utctime,latitude,ns,longitude,ew,qual ity,satellites,hdop,altitude,,,,,
    Input2=GPRMC,,,,,,,speed,course,utcdate,,,,
    speedMultiplier=1.851998
    speedOffset=0.0
    Prefer=1

    [Default Simulation]
    Speed=1.000000


    Any thoughts appreciated. Regards.

  4. #3
    22merlin is offline Lance Corporal
    Join Date
    Aug 2010
    Posts
    14
    Thanks
    0
    Thanked 3 Times in 2 Posts

    Re: Converting Sony NV-U93TW to IGO - advice please

    OK - I have a solution and must thank 'banjokazooie' who posted this elsewhere on the net.
    This should work for all Sony devices. Recommended that files are put on the root directory of the device as reading from a card may not be quick enough.
    You will need to provide a version of Primo [or IGO] that suits your device, this program will enable you to find the GPS signal.
    Download this file [not sure if I've done this right] GPS platform.rar
    Rename you original Sony file and then copy contents to the root directory of the Sony device.
    You may need to edit the new nav-u file to point at your navigation program.
    Run GPS detection program then start the nav. Should work fine.

  5. #4
    Zeppelin is offline Corporal
    Join Date
    May 2010
    Posts
    18
    Thanks
    0
    Thanked 1 Time in 1 Post

    Re: Converting Sony NV-U93TW to IGO - advice please

    @22merlin

    I also have been trying for ages to get Primo working on my Sony 93T.
    I`ve done what you said but when I try to run the gps detection programe on the device it just pops up a boxed message (saying its an application file, modified on.., size...) but does not run.
    Am I doing something stoopid?

    What I`ve done so far is-
    Got Primo running ok on my Sony but not detecting signal.
    Downloaded the GPS platform.rar
    Copied the menu folder onto the Sony root
    Tried to run gps file but it won`t!

    Any other info you can give me or a step by step guide to how you got it working, please

  6. The Following User Says Thank You to Zeppelin For This Useful Post:


  7. #5
    Cosmic Blue is offline Sergeant
    Join Date
    Jul 2010
    Posts
    32
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Converting Sony NV-U93TW to IGO - advice please

    Zeppelin

    Did you rename and then copy the file to the directory instead of the original as you need to edit the file to point to the new maps and exe files.

    If you just coped the file and then edit it without renaming you would have a conflict and the program would not run.

    what happens when you run the gps program ? does it locate the proper com file ?

  8. #6
    Zeppelin is offline Corporal
    Join Date
    May 2010
    Posts
    18
    Thanks
    0
    Thanked 1 Time in 1 Post

    Re: Converting Sony NV-U93TW to IGO - advice please

    Thanks everone, now got Primo running perfectly on my Sony.

    I used the "gps platform rar" file, renamed sony file on my device, edited the new sony file-Thanks Cosmic Blue- and copied the menu and sony file to the mounted volume. Reset and hey presto everything worked!

    I think, but not sure, that by copying the files to the mounted volume, Primo loads and runs straight away and I dont get the Menu screen of the gps platform program. Happy as it is anyway

  9. #7
    astraclub is offline Lance Corporal
    Join Date
    Dec 2010
    Posts
    14
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Converting Sony NV-U93TW to IGO - advice please

    Hi
    Can someone please help
    I had accidently removed Mounted drive from device to my laptop and uploaded igo8
    I have got "initialization error-language file not found"
    so- no igo working and original file removed from device to laptop.
    i tried to work original oem data from memory stick but no joy
    i am not been able to see a device drive icon (with explorer) on my laptop so that i could reload the original program back on device.
    can someone outthere please help/.
    my device is like a brick at the moment
    please help

    regards
    AC

  10. #8
    Tee_J is offline Staff Sergeant
    Join Date
    Aug 2011
    Posts
    75
    Thanks
    14
    Thanked 7 Times in 5 Posts

    Re: Converting Sony NV-U93TW to IGO - advice please

    Quote Originally Posted by Zeppelin View Post
    Thanks everone, now got Primo running perfectly on my Sony.

    I used the "gps platform rar" file, renamed sony file on my device, edited the new sony file-Thanks Cosmic Blue- and copied the menu and sony file to the mounted volume. Reset and hey presto everything worked!

    I think, but not sure, that by copying the files to the mounted volume, Primo loads and runs straight away and I dont get the Menu screen of the gps platform program. Happy as it is anyway
    Quote Originally Posted by 22merlin View Post
    OK - I have a solution and must thank 'banjokazooie' who posted this elsewhere on the net.
    This should work for all Sony devices. Recommended that files are put on the root directory of the device as reading from a card may not be quick enough.
    You will need to provide a version of Primo [or IGO] that suits your device, this program will enable you to find the GPS signal.
    Download this file [not sure if I've done this right] GPS platform.rar
    Rename you original Sony file and then copy contents to the root directory of the Sony device.
    You may need to edit the new nav-u file to point at your navigation program.
    Run GPS detection program then start the nav. Should work fine.
    Hi 22merlin, Zeppelin, and Cosmic Blue! You may have saved the day for me (I hope you're still on this forum to read this)! I also have a Sony NAV-U 92TW that I was given and subsequently found out that there were support "issues". Anyway I wanted to convert over to IGO and got stuck with the memory limit of the device - 2GB. I purchased a 4GB Pro-Duo hoping I could mve the 1.8GB map file across - failed. Your posts may have saved the device from being junked! I love the wide screen and the loud speaker volume! But I digress... I hope you can clarify a point or two for me:

    22merlin: When you say "Rename you original Sony file and then copy contents to the root directory of the Sony device" you mean I should rename the nav-u.exe file to something else, say for example, nav-u2.exe, and then copy that file to the root? Or did you mean copy ALL the contents of the Sony folder up to the root of the device i.e. same level (but not in) mounted volume?

    When you say "You may need to edit the new nav-u file to point at your navigation program" (I'm assuming this "new nav-u" file is in the d/load you provided?) what exactly did you mean by "edit...to point at your navigation program"? Which navigatn program? The renamed nav-u.exe copied file in the root folder or the renamed nav-u.exe file in the Sony folder under mounted volume?

    Cosmic Blue: you asked "Did you rename and then copy the file to the directory instead of the original...?", to which directory are you referring?

    22merlin: I found the solution you made mention of...but couldn't really make head or tails of it so am hoping that as you were able to successfully resolve for yourself, you could help me, because I'm out of my depths when it comes to this.

    With your expert guidance, I'm sure I too will soon be the proud user of IGo on a NAV-U!

    Huge thanks!

    Tee_J
    Last edited by Tee_J; 15th October 2011 at 23:04.

  11. #9
    Join Date
    Dec 2011
    Posts
    1
    Thanks
    0
    Thanked 2 Times in 1 Post

    Re: Converting Sony NV-U93TW to IGO - advice please

    Here a new version of jan 7 2011.

    Small version,

    2shared - download Mounted Volume.zip ... olume.html

    Look here voor Igo Primo 2010

    viewtopic.php?f=718&t=127686

    Rename the original file Mounted Volume\Sony\nav-u\nav-u.exe on the pna to nav-u2.exe

    To go back to Sony software, rename the saved nav-u2.exe to nav-u.exe

    Unzip the download file to for e.g. c:\Mounted Volume

    Copy c:\Mounted Volume to the pna with active sync, use Windows xp with Active sync 4.5 and not Vista.

    Reset the pna and look.

    You have to fill your self the content folder with your own maps , voices etc.
    Only the basemap and Monaco is in the zip file, voice Dutch and language English, to keep the zip file small.

    Only the new maps of Igo 8.3 will work!

    This is the structure of the folders:

    Mounted Volume
    ---Igo8
    ¦ +---content
    ¦ ¦ +---building
    ¦ ¦ +---dem
    ¦ ¦ +---lang
    ¦ ¦ +---map
    ¦ ¦ +---phoneme
    ¦ ¦ +---poi
    ¦ ¦ +---scheme
    ¦ ¦ +---speedcam
    ¦ ¦ +---texture
    ¦ ¦ +---userdata
    ¦ ¦ +---voice
    ¦ +---defaults
    ¦ +---license
    ---Sony
    >>> +---nav-u

    On Sony U-71T.

    change in nav-u.mscr
    RunWait("\Mounted Volume\Sony\nav-u\ToolDevice.exe","off 18")
    RunWait("\Mounted Volume\Sony\nav-u\ToolDevice.exe","off 15")

    with

    RunWait("\Mounted Volume\Sony\nav-u\ToolDevice.exe","off 19")
    RunWait("\Mounted Volume\Sony\nav-u\ToolDevice.exe","off 17")


    and igo8 will find GPS
    Thanks to metaxa of Pccwarez

    Maybe the same on U-83T, but on U93T it stays 18/15 thanks Kukabuvar

    You can choose between Sony original software and Igo8 after you have put my version in the download above,
    if you have renamed the original nav-u.exe to nav-u2.exe.
    For this you have to reset the pna to get the choice again.

    Always reset your pna also, with the small button next to the ac/dc, if you putting new software on it.

    Check if you put everthing in the right folder.

    Here the nav-u.mscr what at startup is running if you use the files from my zip file.

    You see it is very simple, so you see why you have to rename the orginal Sony software to nav-u2.exe.
    If you answer at startup with no, this line is executed: RunWait("\Mounted Volume\Sony\nav-u\nav-u2.exe")
    The orginal nav-u.exe is 6 or 7 mb, (becomes nav-u2.exe after the rename), the one in the zip file is 8000 kb, what is starting the script.

    Igo8 has to be "\Mounted Volume\iGO8\iGO8.exe", look line RunWait ("\Mounted Volume\iGO8\iGO8.exe")


    RegWriteDword ("HKCU", "ControlPanel\Volume", "Mute", 5)

    Kill ("SonyCalibMan.exe")

    Close("SonyAppMan")

    Copy("\Mounted Volume\Sony\nav-u\MortScript.exe","\Windows\MortScript.exe")
    Copy("\Mounted Volume\Sony\nav-u\toolhelp.dll","\Windows\toolhelp.dll")
    Copy("\Mounted Volume\Sony\nav-u\TestMode.exe","\Windows\TestMode.exe")
    Copy("\Mounted Volume\Sony\nav-u\PowerOn.mscr","\Windows\PowerOn.mscr")

    RunOnPowerOn ("\Windows\MortScript.exe","\Windows\PowerOn.ms cr" )

    RunWait("\Mounted Volume\Sony\nav-u\ToolDevice.exe","off 18")
    RunWait("\Mounted Volume\Sony\nav-u\ToolDevice.exe","off 15")
    RunWait("\Mounted Volume\Sony\nav-u\ToolDevice.exe","on Serial")

    Run ("\Windows\TestMode.exe")
    Sleep (50)
    Kill ("TestMode.exe")

    While (TRUE)
    RunWait ("\Mounted Volume\iGO8\iGO8.exe")
    PowerOff
    EndWhile


    Here the sys.txt file Igo8 I using on Sony navi
    [interface]
    resolution_dir="480_272"
    vga=0
    shutdown_time=0

    [rawdisplay]
    class="landscape"
    screen_x=480
    screen_y=272

    [folders]
    app="Mounted Volume\iGO8"
    ;sdcardpath="\MemoryStick"
    ;content="\MemoryStick\iGO8\content"

    [debug]
    skip_eula=1
    enable_roadshadow=1

    [map]
    auto_nightmode=0

    [msnd]
    msnd.start=0

    [tts]
    always_say_road_names=1
    announce_street_name=1

    [sound]
    queue_length=200
    ding=0

    [gps]
    port="5"
    baud="57600"


    With the startup script and sys.txt you can use also other IGO8 versions if you like.

    Here a list what device should by working:

    NV-U92T,NV-U82,NV-U72T and NV-U52 are NOT compatible with Microsoft Windows Vista so use Windows xp with active sync 4.5

    NV-U93T, NV-U83, NV-U73T and NV-U53 are compatible with Microsoft Windows Vista
    Download Windows Mobile Device Center 6.1 or later from the Microsoft support site, if not already installed.

    If you use an American pna with own Sony communication software.

    Use preferred Windows xp, install active sync 4.5

    Thanks to DVDPhreak of Gpsunderground,

    Installed ActiveSync and changed the setting for connecting to USB only. All other settings for synchronising are disabled.
    After connecting you can browse the contents (from ActiveSync menu) tested with a NV-U73T.

    Look here also,


    Forum GPS24 :: Nawigacja GPS :: Monitorowanie Pojazdów :: Zobacz temat - Backup Mounted Volume NV-U73T i NV-U93TC bez map.

    Look here for aristidesfl his solution of Sony u71t + iGo8 + Standby Button + Back light sensor, but will
    work maybe also on other pna.

  12. The Following 2 Users Say Thank You to desivasileva For This Useful Post:


  13. #10
    Join Date
    Dec 2011
    Posts
    3
    Thanks
    0
    Thanked 1 Time in 1 Post

    Re: Converting Sony NV-U93TW to IGO - advice please

    Hi all,

    Interesting thread on updating the sony pna, I was looking to update my nv-u92tc as I can no longer get speed camera updates. I have Active sync 4.5 installed on my PC, can explore the files, but can not find the nav-u.exe executable file to rename. I have looked in hidden folders, system folders but still no idea of where it is lurking. I can only find these - scSetup and scSetup2 text docs. in the Mounted volume\Sony\nav-u folder. Any pointers would be great, if all else fails I will end up purchasing something more useful.

Page 1 of 4 123 ... LastLast

LinkBacks (?)

  1. 22nd March 2011, 12:42

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •