In case You face any problems with "upgrade" to higher versions 3.xxx to 9.xxx replace also VOICES.
This was the major problem in my case. Original software and equipment (G50) uses *.zip files , I tried to put there
a lot of versions of *zips = not working! Use *.zbi ! So, if You see after start this : "?????" - new language is required.
In Total Commander or any other soft press F3 to see at the top or bottom number of version (v.3.189) and try look
for any other... Good luck!