GPSUNDERGROUND FORUM IS ON SALE
Results 1 to 8 of 8

Thread: TomTom HD Traffic

  1. #1
    nr7489 is offline Private
    Join Date
    Jul 2010
    Posts
    6
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Thumbs down TomTom HD Traffic

    Hello

    I have a TomTom GO 550 LIVE. When I navigate to ‘LIVE services’ in the main menu and select ‘Traffic’ the device tries to connect to the TomTom Traffic server and returns the message “You need a subscription for this TomTom Service (your current subscription may have expired). Visit tomtom.com for more information.” After pressing ‘Continue’ the traffic sidebar shows an exclamation mark sign. In ‘My Services’ TomTom HD Traffic is valid until 2011 and the other services, such as 'Local Search,' all state the same valid until date and have all worked as normal when tested.

    Surprisingly, when using the ‘Operate my device’ function on TomTom Home you can access the TomTom HD Traffic menu and as long as you do not turn off the device, Traffic seems to work as normal!

    Anyone experienced or experiencing this problem? If so, please let me know.

    Cheers

  2. #2
    Join Date
    Jul 2010
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Unhappy Re: TomTom HD Traffic

    I have EXACTLY the same problem with my GO 550 LIVE that came yesterday. Emailed support yesterday afternoon - no reply yet.

  3. #3
    nr7489 is offline Private
    Join Date
    Jul 2010
    Posts
    6
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: TomTom HD Traffic

    Hi wizpip

    I knew I wouldn't be the only one! I emailed TT Support on Monday, still waiting on a reply! Will let you know if I hear anything.

  4. #4
    terrytpot's Avatar
    terrytpot is offline Sergeant
    Join Date
    Jun 2010
    Location
    Derbyshire,UK
    Posts
    37
    Thanks
    7
    Thanked 10 Times in 1 Post

    Re: TomTom HD Traffic

    I wouldn't be surprised if this is related...
    where they had similar issues with Live services on the X40's after updating the navcore to 9.054 and ended up asking their customers to roll back to an older navcore!

  5. #5
    nr7489 is offline Private
    Join Date
    Jul 2010
    Posts
    6
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: TomTom HD Traffic

    I saw this on the TT website and thought the same myself however when I removed application version 9.054 and tried to install application version 8.371, TT Home only offered 9.054!

    This could still be related but it seems TT only recognise it as being a GO x40 LIVE issue and not a GO x50 LIVE issue.

  6. #6
    westentertainer is offline Corporal
    Join Date
    May 2010
    Posts
    18
    Thanks
    0
    Thanked 2 Times in 1 Post

    Re: TomTom HD Traffic

    same here .but why would tt give you a upgrade on the navcore that is supposed to improve things and then take something thats as important as live services??

  7. #7
    Join Date
    Jul 2010
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: TomTom HD Traffic

    Looks like mine's started working all on its own, thank goodness. Just as well, since five days later support still haven't replied to my email!

  8. #8
    nr7489 is offline Private
    Join Date
    Jul 2010
    Posts
    6
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: TomTom HD Traffic

    I think mine has started working all on its own too!

    TomTom Support did email me back saying the following. I will leave it up to yourselves as to what you think!

    "I cannot offer you an immediate suitable solution for this challenge. I have sent your question to our 2nd line technical department.

    I hope to have an answer for you as soon as possible, please bear with us while we find a solution for your query.

    With Kind Regards

    The TomTom Customer Care Team"

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •