Results 1 to 2 of 2

Thread: GO 720 is locked up on the blue logo screen

  1. #1
    blackpawdr is offline Private
    Join Date
    May 2012
    Thanked 1 Time in 1 Post

    GO 720 is locked up on the blue logo screen

    I'm sorry, I'm not trying to hijack this thread, but I couldn't make a new post.
    I have a 720. It worked fine the few times I used it and it spent the rest of its time in the cradle charging.
    I took it off of the cradle and turned it on and it locked up on the blue logo screen and I couldn't get any farther.
    I had to push the reset switch to get it to shut off.
    I deleted all files from the unit and restored from the backup I made "directly out of the box" and got the same result.
    I then tried the "directly out of box with updates" backup and got the same result; blue logo screen.
    I also tried to use the "best navcore for 720" on this site and still got the same result.
    Is there ANY way to fix this problem or is my tomtom hosed?
    Thank you very much for any advice you can provide.

  2. #2
    lemonfish's Avatar
    lemonfish is offline Moderator
    Join Date
    Jun 2010
    Melbourne, Australia
    Thanked 1,445 Times in 305 Posts

    Re: GO 720 is locked up on the blue logo screen

    No problem. I've moved your post to a new thread.

    Something may possibly be corrupt or damaged, either the internal memory or the card. If you are using the internal memory, get yourself a brand new 4GB+ SDHC card and install everything from scratch. Restore your back up or follow this tutorial:

    TUTORIAL: Clean Install - How to install the latest map and navcore from scratch!
    TomTom Tutorials & FAQ
    TomTom GO 730, Navcore 9.051c, 64Mb RAM, Australia 910.4892, Bootloader: 5.5250
    TomTom ONE v1, Navcore 9.170SE, 32Mb RAM, Australia 910.4892, Bootloader: 5.5244

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts