First $5K will acquire this asset before its gone. Please email me at ibro0079@gmail.com

This forum is for sale ( vBulletin license, domain name, and database). Price just reduced to $5K ( this includes gpsunderground.com and gsm4share.com)

Announcement

Collapse

For Sale


The owner is retiring, its time to let go of this awesome community to someone else who can continue the journey. This forum is for sale ( vBulletin license and domain name). Price just reduced to $5K Please email me at ibro0079@gmail.com if you are interested in buying it. The forum generates income from marketing,
adsense, and membership


See more
See less

Mercedes Comand Aps 2009/2010 V4.1 NTG 2.5

Collapse
This topic is closed.
X
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Re: Mercedes Comand Aps 2009/2010 V4.1 NTG 2.5

    I can't make clear what the differences are between the units that are updated and units that are not. In all cases we update the telematics first and then we try to update the map. So in theory all units (upgradable or not) have the same firmware.

    Ideally I want to remove the HU from these cars and compare (or copy) the HDD with another non upgradable. But the MB owners do not want me to take apart their car ...

    I wait for opportunity:
    a. To swap HDD and see if an updated HDD will work on another car HU.
    b. Put the not updated HDD on a HU that was updated before. See if the problem is on HDD or main firmware.
    c. Clone the HDD - see if the clone works. Then we update the HDD image in this site.
    d. To swap DVD drive - just in case there is a fault with the DVD drive.

    But all these need time and effort and some friend that likes to take apart his beloved MB ...

    Comment


    • Comment


      • Re: Mercedes Comand Aps 2009/2010 V4.1 NTG 2.5

        If you read correctly the thread you will see that some people have problems updating with original DVDs ...

        Comment


        • Comment


          • Re: Mercedes Comand Aps 2009/2010 V4.1 NTG 2.5

            Hi Gerry
            Papars is correct. Let me repeat in short.
            In my case (W211, MY2007)
            a) unit was updated in an MB dealer to the latest telematics.
            b) Bought v3 and tried to update - "Map can not be updated -Contact MB service" appeared. - So I sold the DVD set
            c) I got the v4.1 tried to update - "Map can not be updated -Contact MB service" appeared. - So I sold the DVD set
            d) Found the MB bulletin (see previous post) and the Dealer tried to update my unit with v1.1 dvd set (the internal MB set) - Same bloody message....

            Now I am going to buy the v4.1 again .... (a move under a lot of frustration)

            P.S. I do not know about others but if I post something I always state clearly if
            a) I have/have not done it
            b) I have seen it being done
            c) I have heard about it....

            So believe me it is a hell of a story !!!

            Comment


            • Comment


              • Re: Mercedes Comand Aps 2009/2010 V4.1 NTG 2.5

                I did play little bit with my unit.
                As you know is made by Alpine.
                What I didn't know is that it runs windows CE 5.0. (some older units run linux)
                Is using Realspeech Solo and VoCon 3200 for voice playback and voice recognition respectively (google to find out more).
                Is also using gracenote music CD database to recognize titles and artists. In theory you can update this db easily (copy some files in the SD card and the unit will update the drive). I do not think this db includes EU disks.

                I suspect there are more hidden menus.

                HDD is 40Gb made by Toshiba and is IDE.
                The HDD is partitioned in several logical drives. One holds the map and is the biggest. Another, which is 4Gb long, holds the music register. The others seem empty in my case. I can't see why not somebody to clone the drive (with acronis) and upload...

                My unit has maps 1.0. Really old, and is not updating to any version no matter what I try - original or copy disks. No matter what disk I insert I get "unreadable" and few seconds latter "unable to update map". I did 2 telematic updates (The 06.09 and the 01.10) before attempting to update the maps. The drive reads movie DVDs without problem, so I do not think there is a problem with the drive mechanism and the maps are not getting updated.

                We even tried with maps disabled (using DAS). The MB dealer doesn't know what else to do. Has anybody seen the memo on the recommendation to load maps 1.1? Because I haven't and the MB dealer will not show it to me. Maybe there is a special method to update these disks.

                More experiments latter.

                Comment


                • Re: Mercedes Comand Aps 2009/2010 V4.1 NTG 2.5

                  Originally posted by papars View Post
                  I did play little bit with my unit.
                  As you know is made by Alpine.
                  What I didn't know is that it runs windows CE 5.0. (some older units run linux)
                  Is using Realspeech Solo and VoCon 3200 for voice playback and voice recognition respectively (google to find out more).
                  Is also using gracenote music CD database to recognize titles and artists. In theory you can update this db easily (copy some files in the SD card and the unit will update the drive). I do not think this db includes EU disks.

                  I suspect there are more hidden menus.

                  HDD is 40Gb made by Toshiba and is IDE.
                  The HDD is partitioned in several logical drives. One holds the map and is the biggest. Another, which is 4Gb long, holds the music register. The others seem empty in my case. I can't see why not somebody to clone the drive (with acronis) and upload...

                  My unit has maps 1.0. Really old, and is not updating to any version no matter what I try - original or copy disks. No matter what disk I insert I get "unreadable" and few seconds latter "unable to update map". I did 2 telematic updates (The 06.09 and the 01.10) before attempting to update the maps. The drive reads movie DVDs without problem, so I do not think there is a problem with the drive mechanism and the maps are not getting updated.

                  We even tried with maps disabled (using DAS). The MB dealer doesn't know what else to do. Has anybody seen the memo on the recommendation to load maps 1.1? Because I haven't and the MB dealer will not show it to me. Maybe there is a special method to update these disks.

                  More experiments latter.

                  Hi Papars
                  As you probably know I do also have 1.0 Maps

                  My MB dealer only tried to update to 1.1 maps normally - No special instructions (bulettin GI82_85.P-046208 does not also mention any special instructions). (see attachments)
                  Click image for larger version

Name:	spage1.jpg
Views:	1
Size:	81.2 KB
ID:	438469Click image for larger version

Name:	spage2.jpg
Views:	1
Size:	71.0 KB
ID:	438473

                  However I noticed that in the Hidden NTG2,5 menus there is an UPDATE menu (see attachment)- Any idea what this is used for ???
                  Click image for larger version

Name:	swupdate.JPG
Views:	2
Size:	35.4 KB
ID:	438474
                  Rgds
                  George
                  Last edited by gmatj; 4th June 2010, 07:51.

                  Comment


                  • Re: Mercedes Comand Aps 2009/2010 V4.1 NTG 2.5

                    I dont want take your hope, but i have map-data v1.1 and get this silly message too Think, we have not only one problem in this case. The first is, why didnt accept some HU's no orign maps? And why cant someone post an good alcohol-image??

                    At last service in february i get an print from DAS:

                    Installed Navi-DVD: Europe 2008 (V1.1)
                    Current ordering Navi-DVD: Europe 2009/2010 (V4.1) (A 219 827 10 59)

                    So DAS tell me, that i CAN directly update without steps between other map versions...

                    Comment


                    • Re: Mercedes Comand Aps 2009/2010 V4.1 NTG 2.5

                      Originally posted by papars View Post
                      I did play little bit with my unit.
                      As you know is made by Alpine.
                      What I didn't know is that it runs windows CE 5.0. (some older units run linux)
                      Is using Realspeech Solo and VoCon 3200 for voice playback and voice recognition respectively (google to find out more).
                      Is also using gracenote music CD database to recognize titles and artists. In theory you can update this db easily (copy some files in the SD card and the unit will update the drive). I do not think this db includes EU disks.

                      I suspect there are more hidden menus.

                      HDD is 40Gb made by Toshiba and is IDE.
                      The HDD is partitioned in several logical drives. One holds the map and is the biggest. Another, which is 4Gb long, holds the music register. The others seem empty in my case. I can't see why not somebody to clone the drive (with acronis) and upload...

                      My unit has maps 1.0. Really old, and is not updating to any version no matter what I try - original or copy disks. No matter what disk I insert I get "unreadable" and few seconds latter "unable to update map". I did 2 telematic updates (The 06.09 and the 01.10) before attempting to update the maps. The drive reads movie DVDs without problem, so I do not think there is a problem with the drive mechanism and the maps are not getting updated.

                      We even tried with maps disabled (using DAS). The MB dealer doesn't know what else to do. Has anybody seen the memo on the recommendation to load maps 1.1? Because I haven't and the MB dealer will not show it to me. Maybe there is a special method to update these disks.

                      More experiments latter.
                      Wow, thanks for the info! Is comand APS really running CE 5.0...[off topic] Maybe it is possible to run some additional windows ce applications on it, like for example a web browser? I'm definitely gonna look into this... [/off topic]

                      How did you find out about this? Did you use DAS or did you manage to get in the comand system with some hidden menu option. If it is CE 5.0 running and there is an option to get to the operation system level and can do some programming than a solution should be not far away

                      Comment


                      • Re: Mercedes Comand Aps 2009/2010 V4.1 NTG 2.5

                        Originally posted by appelflap View Post
                        Wow, thanks for the info! Is comand APS really running CE 5.0...[off topic] Maybe it is possible to run some additional windows ce applications on it, like for example a web browser? I'm definitely gonna look into this... [/off topic]

                        How did you find out about this? Did you use DAS or did you manage to get in the comand system with some hidden menu option. If it is CE 5.0 running and there is an option to get to the operation system level and can do some programming than a solution should be not far away
                        Ha ha!
                        Yes, I think it runs windows automotive 5.0
                        If you have the latest telematic disk (1.10) in the directory \HU25\093000\A001902\5600_001 you will find the system image files (nk.bin nk2.bin) that are copied to the HDD during telematics update.
                        The HU boots from flash, cpu seems to be SH4.
                        Somebody with knowledge can decompress the files and possibly make modifications.
                        But there is not input device - no keyboard, or touch screen, no usb, no lan, although by doing a quick look in the images I see some drivers for these there.
                        For the rest, have a look at the HDD files.

                        Back to our problem.

                        I took apart my car, and wife complains ...
                        I've swapped the disk with an empty unformated one, the message I got was "installed map is not compatible with existing firmware. Please update map". Update did not work (I tested 1.1, 3.0, 4.1) with the "contact MB" message.
                        I've backed up the directory with the map files on the original disk and deleted the files. Again HU complained about the non existing maps, but again update failed with the "contact MB" message!

                        So, what I have in my mind now regarding why update fails.
                        a. There is something wrong with the HDD. File is missing or disk is corrupt.
                        b. There is something wrong with the HU. Either firmware is corrupt, or is some kind of protection is enabled for no reason. [this way, you go to MB and the DAS will collect the HU data and send to the police etc]

                        I have to find some working unit and do experiment there to get better conclusions or somebody from MB can give a solution as I see there are many people with this problem.

                        Comment


                        • Re: Mercedes Comand Aps 2009/2010 V4.1 NTG 2.5

                          Any idea what is this menu in the unit's hidden menu ?????

                          Click image for larger version

Name:	swupdate.JPG
Views:	2
Size:	35.4 KB
ID:	438475

                          Comment


                          • Re: Mercedes Comand Aps 2009/2010 V4.1 NTG 2.5

                            Personally I do not know. No matter what disk I put in, it always say to insert disk.
                            On HU with single DVD drive (mine is the changer variety) it will try to read some files from the disk and then it will tell you is the wrong disk. Needless to say I have no idea what files is looking, is suspect is for firmware upgrade -not map- upgrade.

                            Comment


                            • Re: Mercedes Comand Aps 2009/2010 V4.1 NTG 2.5

                              Originally posted by papars View Post
                              Personally I do not know. No matter what disk I put in, it always say to insert disk.
                              On HU with single DVD drive (mine is the changer variety) it will try to read some files from the disk and then it will tell you is the wrong disk. Needless to say I have no idea what files is looking, is suspect is for firmware upgrade -not map- upgrade.
                              That is the dead end I have reached as well trying to find out what it was - I have also asked MB and waiting an answer to this !! (hopefully)

                              Comment


                              • Re: Mercedes Comand Aps 2009/2010 V4.1 NTG 2.5

                                Originally posted by papars View Post
                                Ha ha!
                                Yes, I think it runs windows automotive 5.0
                                If you have the latest telematic disk (1.10) in the directory \HU25\093000\A001902\5600_001 you will find the system image files (nk.bin nk2.bin) that are copied to the HDD during telematics update.
                                The HU boots from flash, cpu seems to be SH4.
                                Somebody with knowledge can decompress the files and possibly make modifications.
                                But there is not input device - no keyboard, or touch screen, no usb, no lan, although by doing a quick look in the images I see some drivers for these there.
                                For the rest, have a look at the HDD files.

                                Back to our problem.

                                I took apart my car, and wife complains ...
                                I've swapped the disk with an empty unformated one, the message I got was "installed map is not compatible with existing firmware. Please update map". Update did not work (I tested 1.1, 3.0, 4.1) with the "contact MB" message.
                                I've backed up the directory with the map files on the original disk and deleted the files. Again HU complained about the non existing maps, but again update failed with the "contact MB" message!

                                So, what I have in my mind now regarding why update fails.
                                a. There is something wrong with the HDD. File is missing or disk is corrupt.
                                b. There is something wrong with the HU. Either firmware is corrupt, or is some kind of protection is enabled for no reason. [this way, you go to MB and the DAS will collect the HU data and send to the police etc]

                                I have to find some working unit and do experiment there to get better conclusions or somebody from MB can give a solution as I see there are many people with this problem.
                                I would agree to most however scenario (b) is a bit too much !!!! I have gone to MB to ask about ti and they have n't go a clue !!
                                We are all trying now

                                Comment

                                Working...
                                X