Announcement

Collapse
No announcement yet.

rt6 on ds5 keeps asking for navigation cd, help needed

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • rt6 on ds5 keeps asking for navigation cd, help needed

    i upgraded the maps on my ds5 , now it doesnt map correctly and keeps asking for a navigation cd. What do i do to rectify

  • #2
    Re: rt6 on ds5 keeps asking for navigation cd, help needed

    Instal the maps and that information desapears

    Comment


    • #3
      Re: rt6 on ds5 keeps asking for navigation cd, help needed

      There are 2 possible reasons:
      1) It is possible that the Media you installed the maps from was corrupt. Try installing it again, with engine running and don't interrupt it.
      2) Be aware that to install later maps, you may need to have your system firmware updated before you upgrade the maps. The official navigation software will usually include the firmware on a separate CD / Media if this is necessary, unless you already have the required firmware installed. Scouting about the Forum here may indicate the firmware needed for the specific map update.

      Comment


      • #4
        Re: rt6 on ds5 keeps asking for navigation cd, help needed

        Hi. Generally this happends when the update of a map of a country didn't succeed.
        So it is necessary to update again the map of that country, and then it will work correctly again (it happend so for me once).
        What is difficult is to launch that update quickly before it restarts.
        Connect the usb key before starting, and when the message "checking" appears, quickly press Esc to avoid checking going to its end.
        The Esc press may sometimes escape from the starting of the map update instead of the checking and only it, so try again, and again, until you succeed to launch the map update.
        I had also to try a few times until I could launch the map update, but when finaly this started, I won !
        Be patient and try until you succeed, even if you need hours, but at the end it will be repaired.
        Good luck.
        PS: Firmware should be at least 2.21.

        Comment


        • #5
          Firmware is already at 2.86

          Comment


          • #6
            it happened to me!...
            you must simply install the russia maps, (the european maps are erased),
            and wen the russia maps are instaled you reinstal the european map you want.
            as simple as that!...

            Comment

            Working...
            X