Announcement

Collapse
No announcement yet.

TomTom GO 920 - Changed battery and now Bluetooth won't work

Collapse
This topic is closed.
X
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • TomTom GO 920 - Changed battery and now Bluetooth won't work


  • #2
    Re: TomTom GO 920 - Changed battery and now Bluetooth won't work

    8300 is quite an old application to be using when the current one that TTHome should be offering you is 8351... As each update offers , or is supposed to offer, minor improvements, I'd suggest updating to start off with (I appreciate that it probably worked before but there's nothing to lose in trying) and perhaps getting some new maps to replace the antiques you're using
    In all likelihood it is a hardware failure but short of peering at the board with a microscope and knowing exactly what to look for the chances of finding it are fairly remote (unless you happened to snap a big ole chunk of the board off or left a cable unplugged) so even dabbling with applications that aren't designed for your 920 probably wont achieve anything.. If you ever try swapping a battery again you might want to try and soften the adhesive first by heating it up with something like a hair drier..

    Comment


    • #3
      Re: TomTom GO 920 - Changed battery and now Bluetooth won't work

      I'd go with the unplugged cable theory.

      Comment


      • #4
        Re: TomTom GO 920 - Changed battery and now Bluetooth won't work

        Originally posted by terrytpot View Post
        8300 is quite an old application to be using when the current one that TTHome should be offering you is 8351... As each update offers , or is supposed to offer, minor improvements, I'd suggest updating to start off with (I appreciate that it probably worked before but there's nothing to lose in trying) and perhaps getting some new maps to replace the antiques you're using
        In all likelihood it is a hardware failure but short of peering at the board with a microscope and knowing exactly what to look for the chances of finding it are fairly remote (unless you happened to snap a big ole chunk of the board off or left a cable unplugged) so even dabbling with applications that aren't designed for your 920 probably wont achieve anything.. If you ever try swapping a battery again you might want to try and soften the adhesive first by heating it up with something like a hair drier..
        Even before I changed the battery I'd tried several times to upgrade to 8351 using TT Home, but the TT wouldn't start with this app installed. Reverting back to 8300 fixed the problem. The guy on the TT support line couldn't figure it out either. Apparently I wasn't the first 920 owner to have this issue. Any suggestions Oh Wise One?

        Those maps aren't "antiques"; they're "vintage".

        Comment

        Working...
        X