Announcement

Collapse
No announcement yet.

What card for my GO 720 please?

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • What card for my GO 720 please?



    Hello everyone, I would like to put my tomtom GO 720 up to date

    In the menu I see:

    App 9.510.1234792.1
    OS 842337
    GPS V1.20
    BOOT 5.5120

    But I do not know what map to take to put in.

    I would like to put europe, but which one please (v 995. ....?)

    There is so much version that I do not know what I need to download please

    Thank you for your help

  • #2
    You can use all the maps with version 995_8507. But you must also use the meta for that maps when it is available.

    Comment


    • #3
      I would go with 8507,it has everything. But, as pointed out abov, the meta, when posted, is essential. And FastActivate to complete the activation process.

      Comment


      • #4
        you gents are outstanding, many thanks for all the help exactly what I am now running

        Comment

        Working...
        X